PDA

View Full Version : problem with SDMove and App_2_SD_Pro on Alpine



pageauc
05-03-2012, 11:10 AM
I have been trying to find a way to move specific movable android applications from the system flash drive to an installed 16GB SD card. Looking for any help or advice on getting this to work since it will make more room for applications. I am using original firmware.

I tried installing SDMove_0.10.apk from android lovers web site. This application will not install at all and gives no message.

Installed App_2_SD_Pro_v2.40.apk and also App 2 SD Pro (move apps to SD) 2.32.apk. Both install OK and the interface works by showing apps that can be moved as well as the menu bar for settings, etc. When you try to move any movable apps the application says "Failed to Move Application", with no other explanation or logs. I did find a mention of removing /mnt/secure/asec/smd12tmp1.asec but this file does not exist on the Alpine (used terminal app with super user rights)

I was also thinking of going into a terminal session and moving an application to a folder on the sd card and creating a unix link eg ln -s destfilename linkfilename with the link name on the flash drive the same as the moved apk file name on the SD card. Since the link file is very small it does not take very much room. Not sure if android will recognize the link file and redirect to destination seamlessly though. Hoping to give this a try.

I have been successfully sharing my Alpine 16GB SD card by running SAMBA Filesharing with z4root so not sure if this is causing a problem with moving the movable apps to the SD card. I really don't want to give up SAMBA sharing. There is also mention of partitioning the SD card but have not tried this.

Still looking for a solution to this problem. Has anyone had any luck with moving movable applications to the SD card on either original or matrix firmware.

Thanks

Still looking for a solution