Results 1 to 4 of 4

Thread: File System Contains Errors

  1. #1
    Join Date
    Nov 2012
    Posts
    3

    Default File System Contains Errors

    Hello everyone. Sorry for the big wall of text but its been a long few days messing with this.

    I am having issues with my Javelin S4. My house loosed power doing hurricane Sandy. Unfortunately I did not get to unplug it before our generator was turned on. Now we are back on city power I tried to power up the javelin S4, but the unit would not boot. It would power on and the 4 hdd activity lights would flash from hdd1 to hdd4 once every 2 min or so and lan led lights up; the status light stays a red or amber color.

    I have tried to hold down the power button for up to 1 min with nothing happening. If I remove the power cord wait 1 min and try again I get the same thing. I was able to boot the unit by removing all 4 hdd's (configured in raid 10). The unit booted and I could access it from the IP address I have assigned to it. I then proceeded to install all 4 hdd's back in 1 at a time. I made it to the 4 hdd ok, once I installed it the system started to rebuild the array.

    10 hrs later the rebuild was finished, I had 4 blue status lights next to all 4 hdd's but the system status light remained a red or amber color. I then tried to reboot the unit from the web interface. When the system went to boot back up it was back to the same problem.

    Again I went through the same routine again, 10hrs later after another rebuild. So I tried another time, the first 2 times it would rebuild the array on disk 4 the 3rd time I tried it, it wanted to rebuild disk 3 and 4.

    Also in the web interface just about every page shows "File System Contains Errors please check file system status." When I click on files system management, then select my array and then click "Check File System" the System Status light will change from red/amber to blue but the progress bar never moves past 0% and then the status light will change back to red/amber.

    I think I need to reflash the firmware but it will not let me do that.

    Any other suggestions on how I can recover this unit or get access to my files on hdd's.

  2. #2
    Join Date
    Nov 2012
    Posts
    3

    Default

    Looks like my problems is with my hdd's. I played around with it more today, and the system will not boot if I have all 4 drives in at once. I found another hdd laying around and booted the system with that 1 drive installed and allowed it to format the drive. Now all menus work status light went from red/amber color to the normal blue color. I shut the system down and installed the 4 hdd's configured as raid 10 back in and the system will not boot. It will b0ot with any configuration of the 4 drives ie drives 1,3 installed or 2,4 or 1,2 or 1,4 will boot but not all 4.

    If I boot with 1,3 installed and then shut the system down via web interface; install disk 2 and boot up then shut down and install disk 4 the system will not boot. But now I have had disk activity on disk 2 and 3, no status light for those drives just activity and a red/amber system status light for the past 1 hr or 2.


    I have a old backup of my data but it is old. Is there still a chance that my data is intact and can I recover it some how? Can I connect these drives to either a motherboard with intel ich10 raid or to a IBM m1015 raid card and retrieve the data off them?

  3. #3
    Join Date
    Nov 2012
    Posts
    3

    Default

    no one has any help????

    Well to late. I could not recover my data. I had to delete the array and recreate it again, then restore from old backup. Lost some data but atleast I did not lose all data.

  4. #4
    Join Date
    Jul 2012
    Posts
    7

    Default

    I'm in the same boat now. It appears to be a bug in the firmware, where it recognizes the drives are fine and the RAID set is also fine, but some bit isn't being flipped to tell it to mount the RAID volume.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •