Results 1 to 2 of 2

Thread: Windows 8 "irpstacksize" is too small Error for exteral shared Drive

  1. #1
    Join Date
    Dec 2012
    Posts
    2

    Default Windows 8 "irpstacksize" is too small Error for exteral shared Drive

    I've been looking through this forum and not found a resolution to this error I'm getting in the log files below:

    The server's configuration parameter "irpstacksize" is too small for the server to use a local device. Please increase the value of this parameter.

    I can connect to a share I created on the c:\ drive titled \\JW-Win-8\Warez anytime I try to connect to a shared Drive using USB 3.0 I get invalid password errors on my PBO. I can access the shares from other PC's as well as my XBox 360 but no luck on the PBO.

    I tried this method to no avail:

    I suggest removing your antivirus software, then try to edit registry on your Windows 7 by these steps below:

    1 Click Start, click Run, type regedit, and then click OK.
    2 Locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\LanmanServer\Parameters

    If the IRPStackSize entry is not present in this subkey, follow these steps:

    1) Click Edit, point to New, and then click DWORD Value.
    2) Type IRPStackSize, and then press ENTER.

    Note Type IRPStackSize exactly as it appears. The value name is case sensitive.

    3 Click IRPStackSize, click Edit, and then click Modify.
    4 In the Data Value box, type a larger value, and then click OK.


    Looking through these forums I at least got to a shared folder from my C:\ drive by trying this:

    gpedit.msc -> Computer configuration -> Windows Settings -> Security Settings -> Local Policies -> Security Options -> Network access: Shares that can be accessed anonymously

    Do not enter the whole share path. In my case the share is \\Josh-Envy\Downloads
    I added Downloads

    Close gpedit
    Open cmd prompt
    Type gpupdate /force

    I entered:

    \\jw-win-8\warez
    \\jw-win-8\warez2
    \\jw-win-8\c
    \\jw-win-8\e
    \\jw-win-8\f
    \\jw-win-8\g
    \\jw-win-8\h
    \\jw-win-8\i

    Still being able to see them but get login errors.

    I also tried this:

    Go to:

    1. "Control Panel"
    2. "Network and Internet"
    3. "Network and Sharing Center"
    4. "Change advanced sharing" (on left hand column)
    5. "Change sharing options for different profiles"

    Make the Following changes:

    Network discovery - Turn ON network discovery

    File and printer sharing - Turn ON file and printer sharing

    Public folder sharing - Turn OFF Public folder sharing (people logged on to this computer can still access these folders)

    Media streaming - Media streaming is ON.

    Filer sharing connections - Enable file sharing doe devices that use 40- or 56-bit encryption.

    Password protected sharing - Turn OFF password protected sharing

    HomeGroup connections - Allow Windows to manage homegroup connections (recommended)


    Next, configure the folder you want to share:

    1. Select the folder
    2. Right-click and choose 'Share' from the menu
    3. From the drop-down box select the Everyone (All users in this list) account, making sure permissions are set to 'Reader'
    4. Click the buttons Add, Share and Done.


    Here are some further registry 'tweaks' if this doesn't work:

    WARNING: This requires editing your PC's registry which, if edited incorrectly, can cause Windows systems to become unstable and unusable.
    Follow the instructions below at your own risk.
    Patriot Memory Company is not responsible for any damage caused by following these steps.
    Users assumes all responsibility when making registry changes.

    1. Navigate to the following location in the registry editor (search regedit in the start button).
    MACHINE\System\CurrentControlSet\Control\Lsa\
    2. On the right side, double-click on 'everyoneincludesanonymous' and change the 'Value data' from '0' to '1'
    3. Double-click on 'NoLmHash' and change the 'Value data' from '1' to '0'
    4. Navigate to the following location in the registry editor:
    MACHINE\System\CurrentControlSet\Services\LanManSe rver\Parameters
    5. Double-click on 'restrictnullsessaccess' and change the 'Value data' from '1' to '0'
    6. Close the registry editor

    Finally, restart your PC.

    Still only able to access share created on C:\ Drive

    I only get the login failed error and this is the only error I see in the system log:

    The server's configuration parameter "irpstacksize" is too small for the server to use a local device. Please increase the value of this parameter.

    - System

    - Provider

    [ Name] srv

    - EventID 2011

    [ Qualifiers] 49152

    Level 2

    Task 0

    Keywords 0x80000000000000

    - TimeCreated

    [ SystemTime] 2012-12-29T15:05:17.289401300Z

    EventRecordID 2973

    Channel System

    Computer JW-Win-8

    Security


    - EventData

    \Device\LanmanServer
    000000000100280000000000DB0700C0000000000000000000 000000000000000000000000000000


    --------------------------------------------------------------------------------

    Binary data:


    In Words

    0000: 00000000 00280001 00000000 C00007DB
    0008: 00000000 00000000 00000000 00000000
    0010: 00000000 00000000


    In Bytes

    0000: 00 00 00 00 01 00 28 00 ......(.
    0008: 00 00 00 00 DB 07 00 C0 ......
    0010: 00 00 00 00 00 00 00 00 ........
    0018: 00 00 00 00 00 00 00 00 ........
    0020: 00 00 00 00 00 00 00 00 ........


    I cant make any sense of this, Any help would be greatly appreciated.

    Thanks in advance

  2. #2
    Join Date
    Jun 2013
    Posts
    2

    Default

    Not enough server storage is available to process this command’, is an annoying error that I have come across a couple of times when using some of the machines at work and home over the past few years. This isn’t an error that will affect every user, but, if you do come across it, then here are a couple of reasons as to why it can happen:
    You don’t have a DWORD VALUE for IRPStackSize in your registry
    You have a DWORD VALUE for IRPStackSize in your registry but the data value is set too low...........

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •