Results 1 to 6 of 6

Thread: (SSDs & Older Chipsets) PE32GS25SSDR not working with MSI K8T Neo-FIS2R (MS-6702)

  1. #1
    Join Date
    Feb 2009
    Posts
    421

    Default (SSDs & Older Chipsets) PE32GS25SSDR not working with MSI K8T Neo-FIS2R (MS-6702)

    As the title said:

    My two brand spanking new PE32GS25SSDR (Patriot 32GB Warp SATA SSD) are not working with my MSI K8T Neo-FIS2R (MS-6702) motherboard...

    It's simply not detecting the drives.

    VIA K8T800 (VT8383) Chipset

    "PC Wizard 2008" reports:

    VIA Technologies Inc VT6420 SATA RAID Controller

    But it's my understand (and what the chipset says on it) it's a VT8237.

    In BIOS I have two options:

    VT8237 PATA-IDE Controller
    This setting is used to enable/disabled the VT8237 PATA-IDE controller. Setting options: Enabled, Disabled.

    VT8237 SATA-IDE Controller
    This setting is used to enable/disabled the VT8237 SATA-IDE controller.
    Setting options: Enabled, Disabled.

    BOTH ARE CURRENTLY ENABLED.

    Any ideas?

    Thanks.

  2. #2
    Join Date
    Feb 2009
    Posts
    421

    Default The only solution...

    Question
    Why is my Second Generation Serial ATA hard drive not detected by my VIA Serial ATA controller or motherboard?

    Answer
    Problem: Second Generation Serial ATA hard drives are not detected when connected to a VIA Serial ATA controller. These controllers include the following chipsets:

    * VT8237
    * VT8237R
    * VT6420
    * VT6421L

    Cause:
    Our Second Generation Serial ATA hard drives use autospeed negotiation. This enables our Second Generation Serial ATA hard drives to automatically detect the motherboard data transfer rate, making it backward compatible with First Generation Serial ATA data transfer rates. However, because this technology is so new, some older motherboards are unable to support autospeed negotiation and cannot recognize the drive. This “drive not detected” condition occurs when a chipset is incapable of correctly negotiating the data transfer speed with a Second Generation Serial ATA hard drive.

    Resolution:

    * You can purchase and install a third party PCI or PCI-Express Second Generation Serial ATA controller card for your Serial ATA hard drive(s).
    * To lock the drive at 150 MB/s data transfer rate, install a jumper shunt on pins OPT1, shown in the picture below.

    So I guess considering that the drives do not have pins/jumpers, my only option is to purchase a third party PCI SATA II Controller. :/

    Let me know if there's any other work arounds before I spend more $!

    Thanks!

  3. #3
    Join Date
    Jul 2008
    Posts
    3,601

    Default

    Hi,

    I take it that's the answer you received from the motherboard manufacturer. If so, then I'm afraid there is a limitation in the sata controller and there is no way to get around it. You'll need the pins/ jumpers for the autospeed negotiation. I believe cheap third party PCI Sata II controller should cost about 30 bucks or so.

  4. #4
    Join Date
    Feb 2009
    Posts
    421

    Default

    Yes, I purchased a PCI SATA I controller today for ~$46. Sure, a plain ol' SATA II controllers are cheap, but I really wanted RAID 0 so I could take advantage of both of my drives. The best SATA II controller I found with 4 interal ports (I wanted to use another 250GB HDD for storage) and RAID 0 started out at $50. From what I read, SATA II's speeds were greater than both speeds of the SSD drives and the PCI bus so I hope I made the right choise settling with SATA I.

    Damn shame about the SATA I generation controllers. I can't believe there isn't a software fix!

    Thanks!

  5. #5
    Join Date
    Sep 2009
    Posts
    164

    Default

    There is a fix. Jumper it down to half the speed. That is the only way you can get it working. I had the same problem with my k8t800 motherboard and a sata 2 drive. The WD drives have jumpers to limit the speed of the drives to sata 1 speeds, the hatachi's have a firmware fix. However, I don't believe there is a way to reduce the speed on a patriot torqx.

    The only other way is the one you decided to take. Purchase a good quality sata 2 controller.

  6. #6
    Join Date
    Sep 2010
    Posts
    2

    Default

    Our Second Generation Serial ATA hard drives use autospeed negotiation. This enables our Second Generation Serial ATA hard drives to automatically detect the motherboard data transfer rate, making it backward compatible with First Generation Serial ATA data transfer rates. However, because this technology is so new, some older motherboards are unable to support autospeed negotiation and cannot recognize the drive. This “drive not detected” condition occurs when a chipset is incapable of correctly negotiating the data transfer speed with a Second Generation Serial ATA hard drive.There is a fix. Jumper it down to half the speed. That is the only way you can get it working. I had the same problem with my k8t800 motherboard and a sata 2 drive. The WD drives have jumpers to limit the speed of the drives to sata 1 speeds, the hatachi's have a firmware fix. However, I don't believe there is a way to reduce the speed on a patriot torqx.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •