My Patriot Convoy XL device stopped working suddenly when I booted up my computer on Monday, June 11, 2012. When I connect the device to my computer (via usb, sata, or esata), the middle green LED turns on for a few seconds, then approximatley six seconds later a sound clicks, then the dual red LEDs turn on and never turn back off.

I have tried the following resolutions and failed to solve my issue:
  1. Changed the RAID type from RAID 1 to all others, both LEDs still red.
  2. Powered from different computers, both LEDs still red.
  3. Took the hard drives out and installed two other working hard drives, both LEDs still red.
  4. Tried installing only one hard drive, both LEDs still red.
  5. powered on device with no drives inside, both LEDs still red
  6. Took out the hard drives, installed then in another properly Patriot Convoy XL, and the hard drives worked fine.


I bought another drive yesterday, and today, the same thing happened! It worked fine for a few hours and then today it stopped working when I unplugged it from my desktop to and plugged it into my laptop . The two red LEDs come on and stay on. I took out the hard drives and put them in another patriot drive (I have several) and the hard drives worked just fine.

So now I have two non-working Patriot Convoys XL (one new and one older).

I opened a support ticket last week, and no one has answered me. Please help me! Thank you.